Print Page | Close Window

Flasher help

Printed From: ukVac.com
Category: Pinball
Forum Name: General Pinball Discussion
Forum Description: General Pinball chat
URL: http://www.ukvac.com/forum/forum_posts.asp?TID=357546
Printed Date: 28 Jun 2017 at 9:53pm


Topic: Flasher help
Posted By: bonehead
Subject: Flasher help
Date Posted: 20 Apr 2017 at 9:03pm
I seem to have no flashers working on my scared stiff pinball. Have tried the relevant fuses and all see ok. Bulbs test ok also.
Looked at the manual but can't seem to find anything else to check.
As none of them are working I guess one transistor could have failed but not all the ones that drive the flashers?

Any idea's where I can look?

Thanks
Steve



Replies:
Posted By: Hurray Banana
Date Posted: 20 Apr 2017 at 9:34pm
Have you checked the connectors on the flasher board in the back box steve, could have become unseated and check the solder joints on the header pins on the board as well.

-------------
http://hurraybanana.london" rel="nofollow - http://hurraybanana.london


Posted By: bonehead
Date Posted: 20 Apr 2017 at 9:40pm
Thanks for the reply. Checked those. Also checked tp2 and have 18v. Just checking wiring again but think I might be transistors or maybe one of the chips on pcb.
Spent ages on it tonight and it's driving me mad!!!!!

I must persist.


Posted By: t-m
Date Posted: 20 Apr 2017 at 11:31pm
Funny that because the flashers on my SS have been driving me mad too!  

You'd be unlucky if all the drive transistors died so sounds more like a power fault.

LED104 should be on, TP104 should have +20v. Fuse F107 should be ok.

Also check the door interlock switch, none of this will work with the door open.  The switch could have gone bad and will cut the +20v.


Posted By: bonehead
Date Posted: 21 Apr 2017 at 7:28am
Ok thanks I will check those test points again. Tried fuses again and sure the door switch is working.

Looks like we both have ss gremlins!!!!


Posted By: t-m
Date Posted: 21 Apr 2017 at 11:15am
Good luck!

Well mine was a bit odd, all the flashers would work under test.  But in use they would only work for about an hour or so then the fuse would eventually blow.  I found some bad connections on the bulb holders so hopefully it's sorted now.



Print Page | Close Window