Print Page | Close Window

Scramble bootleg sound-fixed.

Printed From:
Category: Technical
Forum Name: Tech, Maintenance & Repairs
Forum Description: Need Help? Ask Here
Printed Date: 19 Nov 2018 at 12:01pm

Topic: Scramble bootleg sound-fixed.
Posted By: Lurch666
Subject: Scramble bootleg sound-fixed.
Date Posted: 13 Nov 2017 at 4:39pm
I've decided to start a new thread since this is just going to be about my scramble boot.
In the thread below I covered how I got this board in a working condition:" rel="nofollow -

However I only had the jamma adaptor wired for power and video.
I have added connections now for coin up,player one start and the speaker so I could test the sound but it will not coin up.
I have also set the dip switched to free play and tried the service mode but neither of those work either.Even with the dip set to free play it still says credits:0 at the bottom of the screen.

The board is also unstable.To get it to boot up I have to increase the 5V line to over 5V then bring it down to as low as it can go (about 4.5V).
Then I have to power cycle it and it will run but after about 5 mins it starts to glitch then crash.It refuses to run on anything over 4.5V
I'm thinking this is something to do with the electrolytic caps but wanted to test the sound first.
I have probed pin 37 if the 8255 at 1E that receives the coin up signal and its going low as it should.The other pins seem to be active as well.
The other 8255 at 1D isn't showing much activity but I don't know if that's normal if the game isn't actually being played.
Swapped the Z80 with a known worker and that made no difference.

Going to keep looking but any suggestions would be welcome.

You rang......?

Posted By: andrewsm
Date Posted: 13 Nov 2017 at 6:08pm
Hey, Ive seen many 8255 chips with faulty ports. Try replacing chip for starters.

WANTED: Any Nichi stuff. Need a set of Legs!!" rel="nofollow -

Posted By: Lurch666
Date Posted: 13 Nov 2017 at 7:23pm
Thanks for that.
Ordered some 8255s but the ones in the UK were a bit too expensive so I get 5 from china for about £6.
Will update when they arrive (unless I figure something else out before then).

You rang......?

Posted By: philmurr
Date Posted: 13 Nov 2017 at 8:20pm
You could try swapping the positions of the 2 8255’s and see what you get. Although the 8255 at 1D does drive the protection so the game may just crash depending on what version of software you’re using.

Posted By: Lurch666
Date Posted: 14 Nov 2017 at 9:47am
That's a good idea but both need desoldering.I was hoping to just desolder one and swap it with a new chip to try and get out of doing both but I might do both anyway.
But first I have had another idea.As mentioned in the other thread I got amidar running on this but it was coining up,starting a game and constantly pressing fire.I was puzzled at this behaviour as I have non of the buttons wired up.
Now I know that the 8255 are programmable I'm thinking the version of the games are programming them wrong.I will go back to trying other versions of the scramble roms (there are a few I haven't tried yet) to see if I can get a version that runs and coins up.

You rang......?

Posted By: Macro
Date Posted: 14 Nov 2017 at 1:39pm
I don't think they are programmable in the sense of MCU's - they don't execute any program code. It just means you can change which set of IO ports are being used under program control - the CPU only writes one byte at a time.

If it runs for a little while, I'd start by checking for any hot chips (some chips, like the SRAM for the sprite buffers run hot anyway, but most others should not) - n.b. be careful, using your finger seems like a good idea, but some chips (I still remember a Pentium 90 where the heat sink fan had failed) get hot enough to burn your skin!

Posted By: Lurch666
Date Posted: 14 Nov 2017 at 6:18pm
Maybe programming was the wrong term to use.I'm guessing that it's like an arduino where the inputs and outputs can be used for various things that are defined by the code running on the board.
Maybe one version of scramble expects the coin up to send pin 37 of the 8255 low where another version expects player one joystick up to put pin 37 low.

Actually typing that has given me the thought that if I send all of the non power/video pins of the (non) jamma edge connector to ground maybe one of them could cause a credit to appear.

You rang......?

Posted By: Macro
Date Posted: 14 Nov 2017 at 6:38pm
certainly worth trying coin1 / coin2 and service - all should give credits (depending upon dip switch settings) - or just put it into freeplay!

Dip sw.
    1  2  3  4   5  6  7  8   Coin  Play
    -  -  -  -                 1     1
    +  -  -  -                 1     2
    -  +  -  -                 1     3
    +  +  -  -                 1     4
    -  -  +  -                 1     5
    +  -  +  -                 1     6
    -  +  +  -                 1     7
    +  +  +  -                 2     1
    -  -  -  +                 2     3
    +  -  -  +                 2     5
    -  +  -  +                 3     1
    +  +  -  +                 3     2
    -  -  +  +                 3     4
    +  -  +  +                 4     1
    -  +  +  +                 4     3
    +  +  +  +                 Free Play

Posted By: Lurch666
Date Posted: 15 Nov 2017 at 4:54pm
My scramble manual (the one available on the net) has dip 1&2 off for freeplay but have tried it both ways and it still says Credits:0.
I'm presuming it says free play when the dip switches are set correctly.I can't check on mame as the free play option seems to be missing (0.188).
Also tried grounding one by one all the other pins on the 8255 (that handle player movement,fire and all the other buttons) but got no sign of life.Since the dip switches also work through this chip it's looking duff unless I have the wrong version of scramble but:

Spent a day of erasing and flashing eproms (why does this one need EIGHT program roms) and this is what I found.

The roms named s1.2d to s8.2p that appear in most of the versions of scramble in mame are all identical and produce the boot loop where I get the grid then the score appears at the top,the grid clears except for the squares level with the scores then it goes back to the grid filling the screen again.(there's a video of it near the end of the first page in the last thread).

Stearn scramble set1 roms 2d-2p just gives me garbage.Does not even get to the grid.
Stearn scramble set2 roms 2d-2p gives me the boot loop again.

scramble (bootleg) roms r1.7f1-r5.1l gives screen of characters moving that looks like a test pattern then 'BAD ROM'-checked all the roms including the sfx roms but couldn't get past this.

Scramble (bootleg on galaxian hardware) scramble.1k-scramble.3j gives just a grid.

Scramble (bootleg?) roms 1-8
Bomber (clone) roms 1.3l-8.3a
Strafe bomb (clone) roms 1.2c-8.2p
All run but will not credit up.

So either I have a super rare bootleg that doesn't have the correct roms on mame (doubt it) or I will be doing a LOT of desoldering soon.

You rang......?

Posted By: PaulSwan
Date Posted: 16 Nov 2017 at 3:34am
From the pictures on your prior thread, it appears you have the MU-1 top (with a Zaccaria serial number) and a Konami original bottom with Stern ROMs. At least your set is mismatched in that respect.

Zaccaria officially licensed both Scramble & Super Cobra and I've seen them run either Zaccaria boards or Konami. I'm not sure what game might have been on an MU-1 set with a Zaccaria label. Possibly some other game, maybe Amidar.

If you haven't already, check the underside of the boards for wire-strap hacks that might indicate a conversion. There are hacks that move the interrupt pin and shift the ROM addresses around for other games.



Posted By: Lurch666
Date Posted: 16 Nov 2017 at 10:33am
The only mod is the one near the dip switches on the smaller board.there are a load of yellow and orange wires that I thought were standard but I have just googled some images of the same board to find those appear unique to mine.Will now have to check the schematics to see what they do.Thanks for the info dude.

EDIT:After a quick look it seems that those wires just tie the player one and player two controls together so both can use the same joystick.

I have desoldered both 8255s but got a bit clumsy with the first one (1E) and it didn't survive.
I tried the other one at E1 once I removed it but no difference but that one could be faulty as well.

You rang......?

Posted By: obcd
Date Posted: 16 Nov 2017 at 8:08pm
The 8255 chips have different modes of operation, but likely they are set to generic io which means the cpu has 3 registers that read the status of the 3 I/O ports. If the cpu writes to it, it can set the bits of the I/O ports high or low. Those chips are pretty basic as they are rather old.

Posted By: Lurch666
Date Posted: 19 Nov 2017 at 6:13pm
So I've been experimenting a bit.
Since I could get the amidar clone that runs on scramble hardware to run (see previous thread) and it coins itself up then starts playing by itself I decided to burn it again and try it to see if there's any difference running it without the 8255s in the top board.
Nope-it still jumps to 7 credits then starts a two player game.So either the fault lies elsewhere or the amidar software is looking in the wrong place for it's inputs.
While Amidar was running I tried the sound but got nothing but that again could be because the one 8255 that survived desoldering might be duff.

Also after reading PaulSwans post again it got me thinking.If the main board is Konami why won't it run Konami Scramble? (It just bootloops)
I went to mame and renamed the stern roms (which bootloop on my board) and renamed them to the same as Konami roms and tried it in mame-they run fine.Go figure.

Looking around this forum I found the mod for freeplay on scramble.Since the dip switch setting didn't work I added the mod to the stearn roms2 and tried them.Forgot that stern scramble doesn't work on my board-another dead end but at least I'm eliminating some things.

Hopefully when the 8255s arrive they will make a difference.

You rang......?

Posted By: Lurch666
Date Posted: 20 Nov 2017 at 9:15pm
Tried to get galaxian running on my scramble board today just for the hell of it.I used the bootleg 4 roms from mame that had 5 2k rom images and burned them to the first 5 roms of my scramble but no go.
Is it even possible to run galaxian on a scramble board?All my searching just turns up running scramble on a galaxian board.

Also been reading my old posts and found something I had forgotten.The eproms that were originally in this board were the stern set 1.But on burning a good set all I'm getting is garbage so I'm now thinking this set might be protected.Philmurr mentioned in the other thread that I could NOP myself some instructions to get an unprotected version of the stern romset but can't find anything about it on the net.
Maybe it was a modified version that was running originally on this boardset and that's why a clean version of the stern roms don't run.

You rang......?

Posted By: Lurch666
Date Posted: 28 Nov 2017 at 11:03pm
I'm still waiting for my set of five 8255s from china but last Friday I ordered one from France because I can't wait to see if it fixes the credit problem.

It turned up today so I put it in and now it credits up and plays.
Still can't test the sound because that needs another 8255 as I removed them both so will carry on waiting for the Chinese ones to turn up to finish this repair.

Still curious to see if I could have run a stern set 1 on this board as that's what was burned to the roms that were on the board when I got it but I have not been able to find an unprotected set anywhere.
Oh well I was just curious to see if this problem was down to hardware or an incorrect version of the roms and that question had been answered.

Thanks for all the input dudes (but I might need a bit more if the sound doesn't work after replacing the other 8255).

You rang......?

Posted By: Lurch666
Date Posted: 07 Dec 2017 at 4:41pm
I got the other 8255s the other day,put one in and the sound sort of works.
The volume is loud for the intro tune and background sound but bomb,shots and explosions are quiet.
Looking around these forums I found the culprit was probably one of the 4066 chips.I got some replacements today and tried piggybacking them but it made no difference.

I am wondering if there is any way I could find the faulty 4066 somehow without having to desolder them one by one?

You rang......?

Posted By: Lurch666
Date Posted: 10 Dec 2017 at 2:18pm
Got round to replacing all three of the 4066 chips but now sound seems worse.
I get good bomb and explosion effects (which I didn't have before) but now the intro tune and bullets are so quiet I can barely hear them.
Tried removing all the 4066s and was surprised to find I still got some sounds.I thought all the sound went through those chips?

You rang......?

Posted By: Lurch666
Date Posted: 06 Feb 2018 at 9:42pm
Nearly have this sorted but for one issue that's kicking my butt.
As stated in my previous post the bomb and intro tune are quiet but that's on a psu that has -5 volts.
When I try it in my test rig that has a psu that DOESN'T have -5 the into tune and background hum are really loud.Once another sound effect is played (bomb/shot or explosion) the background hum goes to a normal volume.The sounds stay fine with them all being the same volume even if  I start another game.If I turn the game off the intro sound/background noise return to being too loud again.

So If the board has -5 volts the sounds stay at a constant volume but the into music/background noise and the shots are too quiet.
If it doesn't have -5 volts the intro sound/background start off too loud but change to normal once another sound is played.

The only place I can see the -5 volts going to is the op-amp and that is also connected to a 10uf capacitor.I have changed the cap but that's made no difference.
Apart from that all the sounds are good and the game plays perfect.

Anyone know enough about the mu-1 board to figure out what I'm missing?

You rang......?

Posted By: Lurch666
Date Posted: 09 May 2018 at 7:11pm
Been a while but got back to this board seeing if I could finally figure out the sound.
After lots of testing I'm still scratching my head but found a post about replacing the 741 (which I think is an amp) could fix the sound.
I'm waiting for  a replacement so I removed the one from my board and decided to test the board without the 741 in to see if I got any sound and....The sounds are exactly the same as with the 741 in the board.What is the purpose of it then?

You rang......?

Posted By: NivagSwerdna
Date Posted: 09 May 2018 at 8:30pm
My 2p worth...

IMHO... it's a buffer between the outputs of the 2xthree channels from AY-3-8910.  The Gain is pretty much 2 since the 2xthree inputs have approx 6k impedance and 6/6=1k which is the 2x the feedback resistor.  So it doesn't really add much gain.

Probably there simply to isolate the mixer parts from the power amp.

(and yes it is old fashioned... needs + and - 5V.)

The 4066 switches (2 on each channel) just switch in capacitance forming a low pass filter with the 1k resistor and hence with no 4066s the sound just feeds straight through. The LPF is about 700Hz with the bigger C and about 3.5kHz with the smaller one and something else 1/2piRC with both.

Posted By: NivagSwerdna
Date Posted: 11 May 2018 at 10:57am
Amended answer above... also...

>>>I removed the one from my board and decided to test the board without the 741 in to see if I got any sound and....The sounds are exactly the same as with the 741 in the board.What is the purpose of it then?

With the 741 removed the sound just passes through the Feedback Resistor... not a good plan from a buffer point of view.

Posted By: Lurch666
Date Posted: 11 May 2018 at 2:27pm
Replacement turned up today so won't be running the board again without it but from what you say it doesn't look like it will make any difference.

Wondering if replacing the 51516 might be worth a try.

You rang......?

Posted By: NivagSwerdna
Date Posted: 11 May 2018 at 2:53pm
Originally posted by Lurch666 Lurch666 wrote:

Wondering if replacing the 51516 might be worth a try.
That sounds like a step too far just now.

Put a new 741 in and make sure you have stable +5 and -5 and then report back

You could always swap the AY-3-8910s (or replace them)... it's only 40 pins each after all. Smile

Posted By: Lurch666
Date Posted: 11 May 2018 at 3:58pm
I have already replaced both of them to get the sound working in the first place but......
FIXED.replaced the 741 and got no sound in my test rig-then remembered that my test rig has no -5 (although I got sound from my scramble in my test rig before I replaced the 741)
But In my cab with -5 the sound is perfect.YAY!
Just don't understand how a component that had all the sound going through it could just affect some of those sounds but I'm just glad my scramble is now fully fixed.

thanks for the input.

You rang......?

Posted By: NivagSwerdna
Date Posted: 11 May 2018 at 4:41pm
Originally posted by Lurch666 Lurch666 wrote:

Just don't understand how a component that had all the sound going through it could just affect some of those sounds
Probably proves the need for the buffer between the mixed channel outputs and the audio amp.

I love a happy ending Clap

Print Page | Close Window