Print Page | Close Window

Pandora's box 2600 jamma trips PSU

Printed From: ukVac.com
Category: Technical
Forum Name: Tech, Maintenance & Repairs
Forum Description: Need Help? Ask Here
URL: http://www.ukvac.com/forum/forum_posts.asp?TID=376001
Printed Date: 29 Mar 2020 at 12:14am


Topic: Pandora's box 2600 jamma trips PSU
Posted By: mx5dob
Subject: Pandora's box 2600 jamma trips PSU
Date Posted: 25 Mar 2020 at 4:19pm
Hi all. Went and bought a crap pandoras box from ebay to while away the isolation hours. Prob is it keeps tripping my PSU when connected. Its got 5 volts going into it. Any idea's?

This is the version:
https://www.ebay.co.uk/itm/for-PANDORA-s-Box-2600-in-1-Arcade-PCB-Jamma-Board-3D-Video-Game-Machine-HDMI/114009298444?ssPageName=STRK%3AMEBIDX%3AIT&var=414293816424&_trksid=p2057872.m2749.l2649" rel="nofollow - https://www.ebay.co.uk/itm/for-PANDORA-s-Box-2600-in-1-Arcade-PCB-Jamma-Board-3D-Video-Game-Machine-HDMI/114009298444?ssPageName=STRK%3AMEBIDX%3AIT&var=414293816424&_trksid=p2057872.m2749.l2649

Cheers,
Paul



Replies:
Posted By: TheDaddy
Date Posted: 25 Mar 2020 at 4:48pm
Could be anything - If its blowing then there is probably a short somewhere. Cheap caps !

Other boards ok on that PSU ?

Dave.




-------------
AKA Wonderboy. If there is such a thing as reincarnation , knowing my luck , I will come back as me !!


Posted By: Flinnster
Date Posted: 25 Mar 2020 at 5:16pm
Pandoras boxes usually only use the 12v in I recall. See if the 5v and -5v pins even go anywhere with a mulletmeter.


-------------


WTD: Outrun DLX(yes REALLY!), Rolling Thunder, PacMania
Parts WTD: Any Dino King / LnB / MushiKing Spare Parts!


Posted By: mx5dob
Date Posted: 25 Mar 2020 at 9:06pm
Originally posted by TheDaddy TheDaddy wrote:

Could be anything - If its blowing then there is probably a short somewhere. Cheap caps !

Other boards ok on that PSU ?

Dave.





Everyth8ng else seems fine. One pcb i dug out if storage appears to be dead so need to check.that too


Posted By: mx5dob
Date Posted: 25 Mar 2020 at 9:13pm
Originally posted by Flinnster Flinnster wrote:

Pandoras boxes usually only use the 12v in I recall. See if the 5v and -5v pins even go anywhere with a mulletmeter.


Will do:)


Posted By: SUPERSPRINT
Date Posted: 25 Mar 2020 at 9:16pm
Originally posted by Flinnster Flinnster wrote:

with a mulletmeter.

Everyone needs a mulletmeter

Take the plastic box off the pcb and have a look for damage 


Posted By: mx5dob
Date Posted: 26 Mar 2020 at 8:10am
Originally posted by SUPERSPRINT SUPERSPRINT wrote:

Originally posted by Flinnster Flinnster wrote:

with a mulletmeter.


Everyone needs a mulletmeter

Take the plastic box off the pcb and have a look for damageĀ 



Good. Plan. Will do!


Posted By: TheDaddy
Date Posted: 26 Mar 2020 at 9:12am
Check PSU works with other things - If it does send the multi back !!! I would not bother messing around with it , Taking it to pieces will void guarantee and waste your time. They will send you a replacement.

Dave.


-------------
AKA Wonderboy. If there is such a thing as reincarnation , knowing my luck , I will come back as me !!


Posted By: Robbiedog
Date Posted: 26 Mar 2020 at 9:19am
The auction link you shared says it's definitely 12v DC?

-------------
I didn't say it was your fault, I said I am blaming you.


Posted By: TheDaddy
Date Posted: 26 Mar 2020 at 9:33am
Originally posted by Robbiedog Robbiedog wrote:

The auction link you shared says it's definitely 12v DC?
 

Yeh good point , It does not say what Amperage it is though so I suppose it could be blowing because of that as 12v on most PSU's that have 5 as well are 2 - 5 amps (Ish). Doubt it will be that as 100's will be using them but worth a look I suppose.

Dave.


-------------
AKA Wonderboy. If there is such a thing as reincarnation , knowing my luck , I will come back as me !!


Posted By: mx5dob
Date Posted: 26 Mar 2020 at 2:46pm
Got it to boot on my old LCD computer monitor/supergun. perhaps the screen res is too high for my cab monitor?


Posted By: gunblade
Date Posted: 26 Mar 2020 at 2:52pm
unless you have a hd crt monitor in the cab then yes- its in the spec listing
lucky you did not blow the horizontal transistor on the chassis


Posted By: TheDaddy
Date Posted: 26 Mar 2020 at 3:15pm
Does it not use CGA (Not as I know much about it , Just wondering ??)








-------------
AKA Wonderboy. If there is such a thing as reincarnation , knowing my luck , I will come back as me !!


Posted By: mx5dob
Date Posted: 26 Mar 2020 at 4:26pm
Originally posted by gunblade gunblade wrote:

unless you have a hd crt monitor in the cab then yes- its in the spec listing
lucky you did not blow the horizontal transistor on the chassis

bloody hell. lucky escape then!
Out of interesst what would happen if that did happen? no picture at all? bad syncing?


might have to buy a used older model at some point for the cab and leave this one for the supergun


Posted By: Flinnster
Date Posted: 26 Mar 2020 at 5:10pm
Some of them can be a bit of a pig to get running on 15Khz. Just because it has the jamma connector is no guarantee sadly.

Not sure what the 'solution' was. Some you held down the menu/setting button on the side while booting, others you just needed to have no connection on the VGA, others needed a new SD card image etc.. etc..
Problem is not knowing exactly what the pcb is inside (ie what was skimped on!) and what combination of hardware & software image has been spliced together by the vendor.


-------------


WTD: Outrun DLX(yes REALLY!), Rolling Thunder, PacMania
Parts WTD: Any Dino King / LnB / MushiKing Spare Parts!



Print Page | Close Window